Freenas 8.0.1, VMWare VSphere 5 (ESXi) and iSCSI

Filed Under (Storage, VMware VSphere 5) by Just An Admin on 06-10-2011

The test hardware

We recently completed the build of our ‘do it yourself’ NAS storage, using Freenas 8.0.1. To put this new setup to work we purchased a secondhand HP DL360 G5 with the following specs:

HP DL360 G5
2 x Intel Xeon 5335 2Ghz processor
24GB internal memory (4×4, 4×2)
P400i SAS cache controller, 256MB with Battery Backup
6 x 73GB 15K SAS disk in RAID6
2 x 1GB LAN interface



With this used hardware we have a dedicated test server we can use to put our Freenas Storage through all different kinds of test. We installed an internal 2GB USB stick in the DL360 and installed VMWare VSphere 5 (aka ESXi 5) on the box and configured or tweaked nothing besides the basic network settings.

As for our network, we have purchased a small NetGear GS108 ProSafe 8-port Gigabit Ethernet switch. This little switch will be our first link between the ESXi/VSphere server and the Freenas storage. The switch is capable of Jumbo Packets (up to 9,720 bytes), but we will not be using it (yet!). We attached the second gigabit LAN interface of the Freenas storage and the VSphere server to this switch to create a simple iSCSI LAN.

We are ready to go!

First test: Windows XP running on iSCSI

We wanted to take it easy on the first test, so we configured the Freenas server to use iSCSI and configured a 250GB ZFS Volume on top of our ZFS RAID. This ‘slice’ will be our first iSCSI disk in VMWare 5.

After attaching the disk to VMWare, we installed Windows XP on our vMWare server, using the iSCSI storage as datastore for this virtual machine. So the complete virtual machine is stored on and running from this iSCSI datastore. To get a good impression of the performance, we installed IOMeter (2006.07.27) and ran the unofficial but generally accepted VMWare Performance test using the 8GB test file from VMKTREE.ORG. You can compare or post your results from this test with other VMWare users on this site: VMWare Unofficial Storage Performance thread.

A first run of the test within our Windows XP installation shows the following, promising values:

 

 

 

 

 

A good first run! As we have installed Freenas, VMWare and the virtual machine without any additional configuration, optimization or tweaking what so ever, we think there is room for improvement.

Second test: Windows XP running in iSCSI – LAN optimized

We have been doing some optimizations on the iSCSI LAN connections. We have changed the following values on the VMWare and  Freenas side on the interfaces that service the iSCSI connection:

– Fixed the interfaces to 1000Mbit (aka 1000baseTX)
– Fixed the interfaces to full-duplex
– fixed the interfaces to an mtu of 1500

After these changes we reran the above test again, with the following results:

 

 

 

 

 

 

It seems that the auto-configure settings on the interfaces in our setup are slowing down connections terribly. A simple tweak for a big improvement.

For our next tests we will try to include statistics from the Freenas side, like Interface Traffic, CPU Usage and physical memory utilization to see how much impact one test has on our Freenas setup.

To be continued.

Incoming search terms:

Post a comment